Ticket #1529 (closed bug: wontfix)

Opened 5 years ago

Last modified 5 years ago

Failed installation nagare with python stackless 3.2

Reported by: farid Owned by: apoirier
Priority: major Component: uncategorized
Version: 0.4.1 Keywords:
Cc:

Description

my virtualenv was active with python 3.2.2 stackless

(nagare)farid@sdm2-compaq:~/www/nagare/nagare-0.4.1$ python
Python 3.2.2 Stackless 3.1b3 060516 (default, Feb 27 2013, 12:42:23) 
[GCC 4.4.3] on linux2
Type "help", "copyright", "credits" or "license" for more information.
>>>

when run :

(nagare)farid@sdm2-compaq:~/www/nagare$ easy_install-3.2 ~/Downloads/nagare-0.4.1.tar.gz

got this message :

Processing nagare-0.4.1.tar.gz
Writing /tmp/easy_install-in3j2s/nagare-0.4.1/setup.cfg
Running nagare-0.4.1/setup.py -q bdist_egg --dist-dir /tmp/easy_install-in3j2s/nagare-0.4.1/egg-dist-tmp-leo62q

  File "/home/farid/www/nagare/lib/python3.2/site-packages/distribute-0.6.31-py3.2.egg/setuptools/sandbox.py", line 33, in <lambda>
    ).read(), "setup.py", 'exec'),
  File "setup.py", line 22
    print 'You must use Python Stackless !'
                                          ^
SyntaxError: invalid syntax

I think print statement was wrong for python 3.2.

Change History

comment:1 Changed 5 years ago by apoirier

  • Status changed from new to closed
  • Resolution set to wontfix

Hi,

The current Nagare version needs Python Stackless 2.x (2.5.2 or above). The in-dev 0.5 version adds support for CPython and PyPy?, still in 2.x. Perhaps Python 3.x will be supported in the future too but no plan yet.

Regards

Note: See TracTickets for help on using tickets.